Page 1 of 1

W-300 Electrical Help

PostPosted: Thu Aug 17, 2017 8:31 am
by Denis
Have a '68 W-300. Rear lights are not working. Traced problem to the circuit breaker and relay mounted by driver's left leg and air vent control. Anybody know the size of the breaker? How about a part number for the relay? I know I can get a generic relay that will work but the connector to this relay is unique and I would rather not cut the wires and add different connectors to make the generic work. Not much room or slack in these wires.
Thanks

Re: W-300 Electrical Help

PostPosted: Thu Aug 17, 2017 10:53 pm
by PwrWgnDrvr
Never, ever seen such a circuit breaker or relay in a sweptline. Are u sure this is a factory part? Post a pic....

Re: W-300 Electrical Help

PostPosted: Fri Aug 18, 2017 2:05 pm
by Hobcobble
PwrWgnDrvr wrote:Never, ever seen such a circuit breaker or relay in a sweptline. Are u sure this is a factory part? Post a pic....


Fuse, maybe? :thinking :thinking

John

Re: W-300 Electrical Help

PostPosted: Fri Aug 18, 2017 2:33 pm
by powerwagon54
D200 camper special and D/W300 and up had circuit breakers mounted on the kick panel behind the e-brake handle. They were for auxiliary lighting.

Re: W-300 Electrical Help

PostPosted: Fri Aug 18, 2017 2:42 pm
by Denis
I have an original '68 Dodge truck manual ( not the full truck manual but the '68 supplement ) and both the relay and circuit breaker are shown along with a note that they were standard only on W-300 and D-300 models. I guess because of the extra clearance lights used. Can't get a picture because I have removed they to match up replacements.
They were both rusty so they must have gotten wet at on time.

Re: W-300 Electrical Help

PostPosted: Fri Aug 18, 2017 3:26 pm
by PwrWgnDrvr
Damn, finally learned something new this yr! :dance
Went out back and looked at the 4 trucks in my backyard that match those models and there they are. One is a parts truck and those parts are clean and not rusty. Make an offer if u don't find them elsewhere.

Re: W-300 Electrical Help

PostPosted: Fri Aug 18, 2017 5:31 pm
by Denis
Power Wagon Driver I sent you a PM.

Re: W-300 Electrical Help

PostPosted: Fri Aug 18, 2017 10:14 pm
by dodgeboykim
My 70 D500 has the same relay for Tail lights. It was bad so I simply made a plug in adapter harness to original plug using a standard relay base for Bosch 20,30 amp relays. Added a standard circuit breaker in original spot and Done and no cutting of OEM harness. :thinking :thinking :thinking :thinking

Re: W-300 Electrical Help

PostPosted: Sat Aug 19, 2017 5:45 pm
by Denis
From another forum the relay is CC # 2906336 and the 15 amp breaker is CC # 1540427. OEM breakers are around 8-10 dollars however the relays are pricey around 75 dollars. I'll just go with a replacement relay and make up an adapter with some Sta-Con's.
Thanks for the info and help.

Re: W-300 Electrical Help

PostPosted: Mon Sep 04, 2017 11:27 am
by Denis
Got the aftermarket relay and breaker, made up an adapter and now lights are working fine again.

Re: W-300 Electrical Help

PostPosted: Mon Sep 04, 2017 2:26 pm
by pismopowerwagon
http://www.ebay.com/itm/NOS-Mopar-1961- ... 1438.l2649

My truck has them also, it was a Camper Special D200 donor cab with the HD wire harness underneath that has plug connection for optional external roof lighting or ? lights.