W-300 Electrical Help

Wiring, lights, heater controls, anything electrical..

W-300 Electrical Help

Postby Denis » Thu Aug 17, 2017 8:31 am

Have a '68 W-300. Rear lights are not working. Traced problem to the circuit breaker and relay mounted by driver's left leg and air vent control. Anybody know the size of the breaker? How about a part number for the relay? I know I can get a generic relay that will work but the connector to this relay is unique and I would rather not cut the wires and add different connectors to make the generic work. Not much room or slack in these wires.
Thanks
Denis
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 12
Joined: Sat Feb 06, 2010 9:32 am
City: Fallston
State: MD

Re: W-300 Electrical Help

Postby PwrWgnDrvr » Thu Aug 17, 2017 10:53 pm

Never, ever seen such a circuit breaker or relay in a sweptline. Are u sure this is a factory part? Post a pic....
PwrWgnDrvr
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
 
Posts: 5049
Joined: Wed Dec 31, 1969 6:00 pm
Location: Walnut Creek, CA

Re: W-300 Electrical Help

Postby Hobcobble » Fri Aug 18, 2017 2:05 pm

PwrWgnDrvr wrote:Never, ever seen such a circuit breaker or relay in a sweptline. Are u sure this is a factory part? Post a pic....


Fuse, maybe? :thinking :thinking

John
User avatar
Hobcobble
Forum Moderator
Forum Moderator
 
Posts: 13497
Joined: Wed Dec 31, 1969 6:00 pm
Location: Lockport, NY

Re: W-300 Electrical Help

Postby powerwagon54 » Fri Aug 18, 2017 2:33 pm

D200 camper special and D/W300 and up had circuit breakers mounted on the kick panel behind the e-brake handle. They were for auxiliary lighting.
User avatar
powerwagon54
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
 
Posts: 988
Joined: Wed Dec 31, 1969 6:00 pm
City: Washougal
State: WA

Re: W-300 Electrical Help

Postby Denis » Fri Aug 18, 2017 2:42 pm

I have an original '68 Dodge truck manual ( not the full truck manual but the '68 supplement ) and both the relay and circuit breaker are shown along with a note that they were standard only on W-300 and D-300 models. I guess because of the extra clearance lights used. Can't get a picture because I have removed they to match up replacements.
They were both rusty so they must have gotten wet at on time.
Denis
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 12
Joined: Sat Feb 06, 2010 9:32 am
City: Fallston
State: MD

Re: W-300 Electrical Help

Postby PwrWgnDrvr » Fri Aug 18, 2017 3:26 pm

Damn, finally learned something new this yr! :dance
Went out back and looked at the 4 trucks in my backyard that match those models and there they are. One is a parts truck and those parts are clean and not rusty. Make an offer if u don't find them elsewhere.
PwrWgnDrvr
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
 
Posts: 5049
Joined: Wed Dec 31, 1969 6:00 pm
Location: Walnut Creek, CA

Re: W-300 Electrical Help

Postby Denis » Fri Aug 18, 2017 5:31 pm

Power Wagon Driver I sent you a PM.
Denis
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 12
Joined: Sat Feb 06, 2010 9:32 am
City: Fallston
State: MD

Re: W-300 Electrical Help

Postby dodgeboykim » Fri Aug 18, 2017 10:14 pm

My 70 D500 has the same relay for Tail lights. It was bad so I simply made a plug in adapter harness to original plug using a standard relay base for Bosch 20,30 amp relays. Added a standard circuit breaker in original spot and Done and no cutting of OEM harness. :thinking :thinking :thinking :thinking
My truck is younger than me.
66 W100. 70 D 500 with 69 Hiab Speed Loader. 96 Ram 3500 Club Cab Cummin's 5 spd. 97 Ram 1500 Club Cab 5.9 gas auto. 83 W200 L/B 360 auto on propane.
User avatar
dodgeboykim
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
 
Posts: 2202
Joined: Wed Dec 31, 1969 6:00 pm
Location: chilliwack.
City: Chilliwack. B.C. Canada
State: Foreign

Re: W-300 Electrical Help

Postby Denis » Sat Aug 19, 2017 5:45 pm

From another forum the relay is CC # 2906336 and the 15 amp breaker is CC # 1540427. OEM breakers are around 8-10 dollars however the relays are pricey around 75 dollars. I'll just go with a replacement relay and make up an adapter with some Sta-Con's.
Thanks for the info and help.
Denis
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 12
Joined: Sat Feb 06, 2010 9:32 am
City: Fallston
State: MD

Re: W-300 Electrical Help

Postby Denis » Mon Sep 04, 2017 11:27 am

Got the aftermarket relay and breaker, made up an adapter and now lights are working fine again.
Denis
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 12
Joined: Sat Feb 06, 2010 9:32 am
City: Fallston
State: MD

Re: W-300 Electrical Help

Postby pismopowerwagon » Mon Sep 04, 2017 2:26 pm

http://www.ebay.com/itm/NOS-Mopar-1961- ... 1438.l2649

My truck has them also, it was a Camper Special D200 donor cab with the HD wire harness underneath that has plug connection for optional external roof lighting or ? lights.
Andy
User avatar
pismopowerwagon
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
 
Posts: 1136
Joined: Wed Dec 31, 1969 6:00 pm
Location: Pismo Beach , Cal.
City: Pismo Beach ,cal
State: CA


Return to *ELECTRICAL SYSTEM HELP*

Who is online

Users browsing this forum: No registered users and 9 guests

cron