Voltage Regulator keeps Frying!

Wiring, lights, heater controls, anything electrical..
Post Reply
JunkHead
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 36
Joined: Sat Aug 25, 2012 10:30 am
City: San mateo
State: CA

Voltage Regulator keeps Frying!

Post by JunkHead » Wed Dec 17, 2014 10:29 pm

Here the issue...I have blown 3 Voltage regulators in the past 3 months. I first replace the original Regulator about 6 months ago just to have it new. I blew the first voltage regulator 3 months ago. Fortunately i had it warrantied and drove it for about 3 months till about a couple of days ago i blew another one. At first i found out my heater fuse was too big and it MAYBE it could have been shorting or arcing and making it past the fuse box to cause this issue. Once i took the heater fuse completely out i decided to put my original 1966 voltage regulator back in the truck...(which still worked) i drove for maybe 10 blocks when i noticed it was not charging anymore. What Do You Guys Might Think The Issue Is>..??????? truck has a new alternator, starter and relay. When the regulators fry i can still drive the truck for more than a couple of days.

-What i have done so far is replaced some of the wiring harness and checked for possible short circuits. I did notice that my fuse box looks pretty rough on the back side, but i have gone through all the fuses and cleaned the terminals. Does anyone know where i might be able to find a 1966 dodge d200 replacement fuse box?

Thanks for your time!!!!!!---JunkHead :thinking :usa

User avatar
dodgeboykim
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
Posts: 2316
Joined: Wed Dec 31, 1969 6:00 pm
City: Chilliwack. B.C. Canada
State: Foreign
Location: chilliwack.

Re: Voltage Regulator keeps Frying!

Post by dodgeboykim » Thu Dec 18, 2014 11:22 pm

powerwagon54 possibly.

halliejean
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 4
Joined: Mon Oct 20, 2014 2:27 pm
City: Citrus Heights
State: CA

Re: Voltage Regulator keeps Frying!

Post by halliejean » Sat Jan 24, 2015 11:41 am

Having the same issues; not sure what to do. I'm on volt/reg#4... tried grounding out & still keeps burning up. Have you had any luck coming up with a solution??? :salut

User avatar
dodgeboykim
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
Posts: 2316
Joined: Wed Dec 31, 1969 6:00 pm
City: Chilliwack. B.C. Canada
State: Foreign
Location: chilliwack.

Re: Voltage Regulator keeps Frying!

Post by dodgeboykim » Sat Jan 24, 2015 2:28 pm

And for me in 40 years of owning Swepty style trucks I have never had recurring voltage regulator problems. I have replaced the odd reg or alt/brush's but that's it :Thumbsup .

User avatar
jwing68
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 156
Joined: Tue Jan 29, 2008 4:49 pm
City: Lethbridge,Alberta
State: Foreign
Location: lethbridge Alberta. Canada

Re: Voltage Regulator keeps Frying!

Post by jwing68 » Sun Jan 25, 2015 5:11 pm

I would back pedal a bit and take a look at what was replaced, is your new alternator functioning correctly ? Have it bench tested to confirm, sounds like maybe a diode issue. Is the regulator confirmed to be grounded correctly ? Did you run any AVR checks after the parts were replaced ? Have a battery that is fully charged when you fire up your new charging equipment otherwise it can charge at a rate that can damage rebuilt alternators and the inferior stock wiring these trucks were built with. :2cents
67 Fargo W100 Sweptline SWB Poly 318
67 Fargo W100 Sweptline SWB Poly 318
68 Fargo W300 dually LA 318
65 Dodge W200 Poly
63 Dodge W300 dually Poly 318
68 Pontiac Firebird 350
2005 HD FXST Custom

halliejean
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 4
Joined: Mon Oct 20, 2014 2:27 pm
City: Citrus Heights
State: CA

Re: Voltage Regulator keeps Frying!

Post by halliejean » Fri Jan 22, 2016 9:13 am

installed solid state regulator from a '75 D-100. Have ECU and re.man distributor; schematic got wet & trying to find previous link for wiring diagram. . .

User avatar
dodgeboykim
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
Posts: 2316
Joined: Wed Dec 31, 1969 6:00 pm
City: Chilliwack. B.C. Canada
State: Foreign
Location: chilliwack.

Re: Voltage Regulator keeps Frying!

Post by dodgeboykim » Fri Jan 22, 2016 1:51 pm

halliejean wrote:installed solid state regulator from a '75 D-100. Have ECU and re.man distributor; schematic got wet & trying to find previous link for wiring diagram. . .

Did you use the dual field alternator with that volt regulator. :thinking
My truck is younger than me.
66 W100. 70 D 500 , 69 Hiab Speed Loader. 96 Ram 3500 Club Cab Cummin's 5 spd. 97 Ram 1500 Club Cab 5.9 gas auto. 83 W200 L/B 360 auto on propane. 09 Yamaha Rhino 700.

RobertGilliam
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 373
Joined: Sat Jul 27, 2013 5:57 am
City: Clinton
State: TN

Re: Voltage Regulator keeps Frying!

Post by RobertGilliam » Tue Feb 16, 2016 10:50 am

Most alternator shops will convert it to a one wire for 45/50 bucks. Eliminates a lot of issues.

LuckyBaldwin
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 28
Joined: Tue May 05, 2015 9:21 pm
City: Stockton
State: CA

Re: Voltage Regulator keeps Frying!

Post by LuckyBaldwin » Fri Jul 08, 2016 1:05 pm

had the same problem when i first bought my '68 W100. went through 3 new regulators in 3 days. the only points style regulators you can get now are made in china and are pure cheese. took each of the 3 regulators apart after they failed and was the points each time. the two contacts aren't parallel. the moving contact hits the stationary one at a 20 to 30 degree angle so that only about 10% of the contact surface area was carrying the full electrical load. is it any wonder they burn up in a day?

i fixed the problem by installing an airtex/wells electronic regulator, p/n: 1V1067

http://www.airtexve.com/custom_searches ... 7#zoom=100

is a single field, plug and play swap with no modifications needed. has charged fine ever since. the instructions said to make sure the regulator is grounded to the body before connecting the wires.

http://www.airtexve.com/custom_searches ... 700268.pdf

User avatar
longbed67
Sweptline.ORG Member
Sweptline.ORG Member
Posts: 177
Joined: Wed Sep 25, 2013 2:21 pm
City: woodlands
State: TX

Re: Voltage Regulator keeps Frying!

Post by longbed67 » Sun Jun 11, 2017 8:05 am

just changed mine over to gm style one wire. took out the ammeter added a voltmeter. system works great now

Post Reply