Z-bar binding, clutch wont engage properly

This area is for the Powerwagon 4X4 Enthusiast!

Z-bar binding, clutch wont engage properly

Postby 69pwag » Tue Mar 28, 2017 9:56 pm

New to the forum (first post),

I have a 69 power wagon with a 318/4 speed setup, mechanical everything. It has a 3" body lift from previous owners. When i press the clutch pedal, my zbar will move but eventually binds up when its almost all the way down. When the clutch pedal is a couple of inches from the floor, it gets really stiff and wants to lift the cab. I adjusted the clutch rod alongside the transmission to see if that would do anything. Now the pedal will go to the floor almost normally, but does not put the transmission in nuetral. With my foot on the clutch and the truck in gear, it will still move.

(When the body lift was put on someone lengthened the clutch rod that goes from the pedal to the z-bar, could it be too long? Looks fine to me because it worked with the previous owner)

This has me absolutely confused, any ideas on what is going on?
69 W200 318 4 speed sittin on 40" ground hawgs
69pwag
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 2
Joined: Mon Mar 27, 2017 5:05 pm
City: Chebanse
State: IL

Re: Z-bar binding, clutch wont engage properly

Postby Hobcobble » Wed Mar 29, 2017 10:26 am

First off.... Have someone press the clutch while you observe how the pedal
rod is traveling through the floorboard. :idea :2cents
John
User avatar
Hobcobble
Forum Moderator
Forum Moderator
 
Posts: 13535
Joined: Wed Dec 31, 1969 6:00 pm
Location: Lockport, NY

Re: Z-bar binding, clutch wont engage properly

Postby 69pwag » Wed Mar 29, 2017 10:45 am

That was the first thing i did.. the clutch rod has a little slop in it you press the pedal about half an inch then the rod will move. Once the pedal goes down and gets stiff, the zbar wants to kindve twist and go into a bind
69 W200 318 4 speed sittin on 40" ground hawgs
69pwag
Sweptline.ORG Member
Sweptline.ORG Member
 
Posts: 2
Joined: Mon Mar 27, 2017 5:05 pm
City: Chebanse
State: IL

Re: Z-bar binding, clutch wont engage properly

Postby digdoug » Wed Mar 29, 2017 6:04 pm

There are nylon bushings in the Z bar. I have seen replacements on ebay. Maybe yours are worn or missing?
http://www.ebay.com/itm/Mopar-Z-Bar-ZBa ... PQ&vxp=mtr
I sold all of my sweptline trucks,except the invisible one. I just couldn't stand to see it go!
( )
91w350 CTD
93w250 CTD
2000 W3500 CTD
User avatar
digdoug
Sweptline.ORG Pioneer
Sweptline.ORG Pioneer
 
Posts: 2839
Joined: Wed Dec 31, 1969 6:00 pm
Location: Genesee,Id.


Return to POWERWAGON 4X4 DISCUSSION

Who is online

Users browsing this forum: Bing [Bot] and 1 guest